Discussion:
[Tails-dev] Fwd: Not happy with my tails experience
(too old to reply)
intrigeri
2014-10-08 17:30:50 UTC
Permalink
Hi,

I'm forwarding this to the Tails support mailing-list.
Please drop -dev@ from the Cc list on next reply. Thanks :)
Emma Peel
2014-10-09 08:02:51 UTC
Permalink
Hello!
I bought 2 new 8 GB transcend USB sticks to get a clean install, not getting trapped by too small or outworn hardware
I checked the SHA256 checksum of the ISO file: correct
I started installing tails on a desktop machine with ALI chipset and AMD64 K8 '3200' with 2 GB RAM
writing the image with (** usbinstalller or so, the actual version) seemed to go on fine.
Some versions of UUI are presenting problems, you will need version 1.9.5.4 or later.
But after booting up from that stick there came a lot of read errors - should be in the syslinux phase - and then 'cannot find path to kernel'
.
I used another desktop machine AMD 2core 4800 or so (dual core) with VIA chipset, 2 GB RAM
similar result added here were colored block glitches on the screen. EDR 0100 read error or the like. seemed to boot, but then got stuck
.
flashed the usb stick anew, now on another machine and also flashed my second new usb stick .
still no success
.
used the stick in a 6 years old laptop with intel celeron 2GHz with intel ihc 5 (?) chipset and 1 GB of RAM.
.
started up ok.
Some boards may haveproblems starting Tails. Did you tried to start it from a DVD?
My critics: In the opening screen, where a root password can be set as well as 3 other options, I got really angry.
root psw: no problem
second choice is windows hiding: what in hell is her the on and the off state of this choice? clicking on the string-field gives either a dark grey or a lighter grey apearance of the text box Why not use a simple checkbox? On Off would be clear.
third choice is mac spoofing. Same unclear staus as above: What is on waht is off?
fourt choice should be a dual choice thing with 2 fields: gateway etc 1) unproblematic versus 2) some work to do but the fields don't toggle each other. AND again here grey versus grey as indicator of choice.
dammit!
The new menu selection can be confusing at first. The selection is part of Gnome. The darker one is selected...
got tails running, created a second stick from within tails to use persistent storage.
the creation process stopped at 98%. no more advance even 15 minutes later
maybe, the open, but unused tor browser (ok, it's iceweasel, but would help naming it TOR in the menue) was hindering the process.
rebooted, got through the grey grey choices, startet the tails tool again this time the stick with persisstent storage was created.
// I was hoping to be through with trouble now, but...
started with that new stick, created a persistent storage on that stick
rebooted
the persistent storage wasn't there. something went wrong while creating it
deleted the non-working persistent storege
created a new persistent storage
rebooted
now success was in reach, as the dual choice box with options did show up a selction for the persistent storage.
checked it, did not check the readonly button.
started on.
In the tails tool I checked all private settings from gpg key over dot-files and browser bookmarks to be held in the persistent storage.
One of the major points for me for using this personal setting is choosing the german keyboard layout. And of course having some bookmarks persistant is a good thing too.
So I set german keyboard, english surrounding, set some bookmarks
As I thought, these settings would be updated in the persistent storage at the moment or at least before rebooting the machine.
nope
no german keyboard layout, no bookmarks.
Is there a special procedure necessary that I might have missed?
Btw: I have put this stick (persistent) into the first mentioned AMD64K8 machine and it is seen in the bios, but while booting , the stick is completely overrun and the first stop is at my grub. Could that have to do with the special type of partition used here?
-
After you configure Persistence, you have to reboot again, as the menu tells you, for the changes to take effect. Unfortunately the language selection is still not part of the persistence setup. We are working on it: https://labs.riseup.net/code/issues/5501

The bookmarks will be saved if created after booting again with Persistence enabled.
ok, this is the end for now.
I AM angry, but not angry on somebody of the tails team, but angry on this situation.
As a fallback and proven solution I have my linux boxes with debian linux and TOR installed. What I was hoping of from tails was a universal dedicated safe and anon linux 'to go' and use on many different machines. Wasn't that the intention?
Yes it is, but Tails is a work in progress. Any bit of help is welcome!
I don't like gnome, all my machines have kde on them. This gnome comes with the menue/status line on top instead on bottom of the screen. makes me crave. Can that pe persistently set to be on the bottom line?
The network settings can be stored in the persistent storage. I just had a peek at it from my debain running. Is it really a good idea to store that data? When going from one machine to another with this one stick, wouldn't it possibly mess things up? With a working dhcp it should not really cost time to live without persistence.
You don't need to save the network settings if you don't feel like. It is mainly useful when you have to add a lot of passwords for joining networks, not for open networks as your case seems to tell.
The 'nm-systems-connections' folder is at least populated with data. The 'Persistent' folder is empty The 'bookmarks' folder contains a places.sqlite file, which seems to be without any links in it The 'dotfiles' folder is empty The 'open-ssh-client' folder is empty, now wonder, haven't used ssh on the tails machine, so no keys The gpg and othe folders are obviously populated with default files
The Persistent folder is for you to add your documents. To see the
changes you configured on the persistence setup, the answer is on your
next line: /live/persistence/TailsData_unlocked/
You should have, as you configured it,

/home/amnesia/Persistent source=Persistent
/home/amnesia/.gnupg source=gnupg
/home/amnesia/.ssh source=openssh-client
/home/amnesia/.purple source=pidgin
/home/amnesia/.claws-mail source=claws-mail
/home/amnesia/.gnome2/keyrings source=gnome-keyrings
/etc/NetworkManager/system-connections source=nm-system-connections
/home/amnesia/.mozilla/firefox/bookmarks source=bookmarks
/var/cache/apt/archives source=apt/cache
/var/lib/apt/lists source=apt/lists
/home/amnesia source=dotfiles,link

If this is not the case (you will need a root password at boot to read the file) please report back.
--
So to sum it up: Is the german keyboard layout pewrsitently possible?
Already answered above, https://labs.riseup.net/code/issues/5501
What's about the bookmarks? manually copy them to persistence folder?
They should be saved, but you need to restart every time you use the
Configure Persistence for the changes to take effect.
A last thought: both machines struggling to run tails at all were AMD
AMDK8 or 486 (includes intel celeron, I think) Could that be a cause
for the readerrors, not finding kernel, not finding the xxxyyyzzz.c32
startfile of (I think) syslinux? Thanks for your time! And PEACE and
GREETINGS and THANKS PS: If needed or useful, I can provide more
detailed information.
Maybe removing 64bit architecture detection:

https://labs.riseup.net/code/issues/7938

will help with this problem.

I hope this helps!

Loading...